Средство диагностики DirectX

Документация средства диагностики Microsoft® DirectX® содержит следующие разделы.

  • О средстве диагностики DirectX
  • На что обращать внимание
  • Тестирование компонентов DirectX
  • Переопределение характеристик по умолчанию


О средстве диагностики DirectX

Средство диагностики Microsoft® DirectX® отображает сведения о компонентах и драйверах интерфейса программирования приложений (API) Microsoft DirectX в данной системе. Оно позволяет проверить работу звуковой и графической систем, а также поставщиков службы DirectPlay®. Оно также позволяет отключить некоторые средства аппаратного ускорения.

Данное средство позволяет собирать сведения для предоставления сотруднику службы технической поддержки при обращении за помощью; собранные сведения также можно сохранить и вставить в сообщение электронной почты.

Сведения отображаются на нескольких страницах. Для переходов со страницы на страницу можно использовать любой из следующих способов:

  • щелкните нужную вкладку;
  • нажмите кнопку Следующая страница;
  • нажмите клавишу СТРЕЛКА ВЛЕВО или СТРЕЛКА ВПРАВО, когда фокус находится на вкладке.

Отображением таблиц в окне данного средства можно управлять. Для этого выберите столбец, по которому требуется отсортировать строки таблицы. Щелкните заголовок выбранного столбца и таблица будет отсортирована по элементам этого столбца в алфавитном или числовом порядке. Чтобы обратить порядок сортировки, щелкните заголовок столбца еще раз.

Нажатием кнопки Сохранить все сведения можно сохранить все сведения в текстовом файле.

Примечание

  • Некоторые сведения, такие как объем памяти на видеоплате, могут быть приблизительными.


На что обращать внимание

Если при использовании приложений Microsoft® DirectX® возникают неполадки, средство диагностики DirectX может помочь установить их источник. Ниже перечислены некоторые диагностические сведения, на которые следует обратить внимание.

  • Неправильные версии компонентов DirectX. В разделе Примечания на странице Файлы DirectX выводятся сведения о бета-версиях и отладочных файлах. Бета-версии — это ранние пробные версии, которые не должны устанавливаться коммерческими приложениями. Отладочные версии, которые используются при разработке программ, также не должны устанавливаться конечными продуктами, поскольку они выполняются существенно медленнее коммерческих версий соответствующих компонентов.
  • Отсутствие аппаратного ускорения. Некоторые программы выполняются очень медленно или вообще не выполняются в отсутствие аппаратного ускорения DirectDraw® или Direct3D®. На странице Дисплей проверьте в группе Возможности DirectX, имеется ли для ускорения DirectDraw, Direct3D или текстуры AGP метка «Недоступно». При наличии такой метки рассмотрите возможность обновления оборудования.
  • Устройство не подключено. Если джойстик или другое устройство ввода не отвечает, возможно, оно было неверно установлено. Убедитесь, что устройство представлено на странице Ввод средства диагностики DirectX. В противном случае добавьте устройство с помощью панели управления.
  • Неподписанные драйверы. Неподписанные драйверы не проверены корпорацией Майкрософт на полную совместимость с последней версией DirectX. Такие драйверы перечислены на странице соответствующего компонента.

Примечание. При использовании служб терминалов для работы на удаленном компьютере, поддерживающем аппаратное ускорение, средство диагностики DirectX может отметить наличие поддержки для аппаратного ускорения. Однако службы терминалов не могут использовать аппаратное ускорение, так что поддержка недоступна.


Тестирование компонентов DirectX

Microsoft® DirectDraw® и Direct3D® можно тестировать на любом мониторе, подключенном к системе. Также можно тестировать DirectSound® на любом устройстве вывода звука, и DirectMusic® на любом музыкальном порте.

Чтобы проверить DirectX, нажмите кнопку Проверить на соответствующей странице, прочитайте появляющиеся сообщения и просмотрите или прослушайте тесты. Позвольте каждому тесту выполняться, пока не появится сообщение с вопросом, был ли тест успешным. Если пользователь отвечает Нет, другие тесты не выполняются.

При проверке DirectMusic выполняется единый тест. Нажмите кнопку OK после ответов на вопросы о качестве воспроизведения звука.

Функциональность Microsoft DirectPlay® можно проверить для всех доступных поставщиков.

Чтобы проверить DirectPlay

  1. На странице Сеть нажмите кнопку Проверить DirectPlay. В диалоговом окне Проверка DirectPlay введите имя пользователя и выберите поставщика. Выберите параметр Создать новый сеанс и нажмите кнопку OK. Если выбрано подключение через модем, нажмите кнопку Ответить в диалоговом окне Подключение через модем, чтобы перевести модем в режим автоответа.
  2. После этого запустите средство диагностики Microsoft DirectX® на другом компьютере, способном установить выбранное подключение с первым компьютером. Нажмите кнопку Проверить DirectPlay, введите другое имя пользователя, выберите того же поставщика, установите переключатель Подсоединиться к существующему сеансу и нажмите кнопку OK.

    Для некоторых типов подключений может потребоваться ввод дополнительных сведений, таких как телефонный номер. Для подключения TCP/IP через локальную сеть поле можно оставить пустым.

  3. На втором компьютере выберите в диалоговом окне Список сеансов имя сеанса, созданного на первом компьютере, и нажмите кнопку OK.
  4. После этого на обоих компьютерах должно быть открыто диалоговое окно разговора. Введите сообщение в поле ввода на одном компьютере и нажмите кнопку Отправить. Введенное сообщение должно появиться в области прокрутки диалогового окна разговора на обоих компьютерах.


Переопределение характеристик по умолчанию

На странице Звук можно изменить уровень аппаратного ускорения, перетащив соответствующий ползунок. Выбранный уровень будет применяться даже после закрытия окна средства диагностики Microsoft® DirectX®.

Можно отключить аппаратное ускорение для Microsoft DirectDraw® или Direct3D®, если таковое доступно. Для этого откройте страницу Дисплей для каждого дисплея и нажмите кнопку Отключить. Отключенное аппаратное ускорение остается отключенным и недоступным для любых приложений даже после закрытия средства диагностики DirectX. Чтобы снова включить аппаратное ускорение, нажмите кнопку Включить на странице «Дисплей» для соответствующего устройства.

Примечание

  • Отключение ускорения DirectDraw приводит к отключению ускорения для Direct3D.

Пользователь имеет также возможность переопределить частоту обновления монитора, установленную полноэкранными приложениями DirectDraw. Это следует делать только в том случае, если у некоторых приложений возникают неполадки с выводом на экран, и есть причины подозревать, что приложение устанавливает недопустимую частоту обновления.

Чтобы переопределить частоту обновления

  1. На странице Если ничего не помогло нажмите кнопку Частота.
  2. В диалоговом окне Частота обновления экрана введите частоту обновления, допустимую для используемого монитора.

    Параметр Другое значение при этом будет выбран автоматически.

  3. Нажмите кнопку OK.

Чтобы отменить переопределение частоты обновления и позволить приложениям DirectDraw задавать собственную частоту обновления

  1. На странице Если ничего не помогло нажмите кнопку Частота.
  2. В диалоговом окне Частота обновления экрана выберите параметр По умолчанию и нажмите кнопку OK.